import re
regex = re.compile(r"^(?=[\p{L}0-9]+-[\p{L}0-9]+)([^.]+\.(?:org|com).*)", flags=re.MULTILINE)
test_str = ("some-thing.org\n"
"some-thing.org.sg\n"
"some-thing.com\n"
"some-thing.com.sg\n"
"some-thing.com.* \n\n"
"some1-thing.com \n"
"sòme1-thing.org\n\n"
"some-thing\n"
"some-thing.moc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")