re = /^(?=[\p{L}0-9]+-[\p{L}0-9]+)([^.]+\.(?:org|com).*)/m
str = 'some-thing.org
some-thing.org.sg
some-thing.com
some-thing.com.sg
some-thing.com.*
some1-thing.com
sòme1-thing.org
some-thing
some-thing.moc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end