#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\w+)\s*(\.=|=|:=)"
Local $sString = "" & @CRLF & _
"x = foo" & @CRLF & _
"x:=" & @CRLF & _
"foo x=" & @CRLF & _
"" & @CRLF & _
"x = foo" & @CRLF & _
"" & @CRLF & _
"foo text :=" & @CRLF & _
"text := x text foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")