re = /\b(\w+)\s*(\.=|=|:=)/m
str = '
x = foo
x:=
foo x=
x = foo
foo text :=
text := x text foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end