$re = '/\b(\w+)\s*(\.=|=|:=)/m';
$str = '
x = foo
x:=
foo x=
x = foo
foo text :=
text := x text foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);