import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\w+)(\\s*[\\w-]+=\"[^\"]+\")*(\\s*data-toggle=\"[^\"]+\")(\\s*[\\w-]+=\"[^\"]+\")*(\\s*>)";
final String string = "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >\n"
+ "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >\n"
+ "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >\n\n"
+ "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >\n\n"
+ "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >\n\n"
+ "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >\n"
+ "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >\n"
+ "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >\n\n"
+ "<a href=\"#\" data-toggle=\"modal\" data-target=\"xxxx\"></a>\n\n"
+ "<a href=\"#\"data-target=\"#available-assistance\" data-toggle=\"modal\" data-modal=\"yeah\"></a>\n\n"
+ "<a href=\"#\"data-target=\"#available-assistance\" data-toggle=\"modal\" data-modal=\"yeah\"></a>\n\n";
final String subst = "$1$3$5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}