use strict;
my $str = '<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<a href="#" data-toggle="modal" data-target="xxxx"></a>
<a href="#"data-target="#available-assistance" data-toggle="modal" data-modal="yeah"></a>
<a href="#"data-target="#available-assistance" data-toggle="modal" data-modal="yeah"></a>
';
my $regex = qr/(<\w+)(\s*[\w-]+="[^"]+")*(\s*data-toggle="[^"]+")(\s*[\w-]+="[^"]+")*(\s*>)/p;
my $subst = '$1$3$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";