#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:Product (\d{6})(\d{8}) (.{12}) (.+)\s?\*BCA)+"
Local $sString = "Account balance PLM051 05May2016 10:54 " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"Actions Submenu View authorisation balance details" & @CRLF & _
"View available balance detailsExit " & @CRLF & _
" " & @CRLF & _
" Product 40256731631234 BUSINESS A/C Zapp Innovat*BCA " & @CRLF & _
" " & @CRLF & _
"Balances as at 05May2016 10:54 except where indicated " & @CRLF & _
" Balance 907.50Cr " & @CRLF & _
" Statement balance 1,059.50Cr (04May2016) " & @CRLF & _
"" & @CRLF & _
" Cleared balance 907.50Cr " & @CRLF & _
" Interest balance 1,059.50Cr (04May2016) " & @CRLF & _
" " & @CRLF & _
" Available balance 793.56Cr " & @CRLF & _
" Authorisation balance 793.56Cr " & @CRLF & _
"Other details " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Account balance PLM051 05May2016 10:54 " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"Actions Submenu View authorisation balance details" & @CRLF & _
"View available balance detailsExit " & @CRLF & _
" " & @CRLF & _
" Product 40256731631234 BUSINESS A/C Zapp Innovat*BCA " & @CRLF & _
" " & @CRLF & _
"Balances as at 05May2016 10:54 except where indicated " & @CRLF & _
" Balance 907.50Cr " & @CRLF & _
" Statement balance 1,059.50Cr (04May2016) " & @CRLF & _
"" & @CRLF & _
" Cleared balance 907.50Cr " & @CRLF & _
" Interest balance 1,059.50Cr (04May2016) " & @CRLF & _
" " & @CRLF & _
" Available balance 793.56Cr " & @CRLF & _
" Authorisation balance 793.56Cr " & @CRLF & _
"Other details " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")