import re
regex = re.compile(r"(?:Product (\d{6})(\d{8}) (.{12}) (.+)\s?\*BCA)+")
test_str = ("Account balance PLM051 05May2016 10:54 \n\n"
" \n"
"Actions Submenu View authorisation balance details\n"
"View available balance detailsExit \n"
" \n"
" Product 40256731631234 BUSINESS A/C Zapp Innovat*BCA \n"
" \n"
"Balances as at 05May2016 10:54 except where indicated \n"
" Balance 907.50Cr \n"
" Statement balance 1,059.50Cr (04May2016) \n\n"
" Cleared balance 907.50Cr \n"
" Interest balance 1,059.50Cr (04May2016) \n"
" \n"
" Available balance 793.56Cr \n"
" Authorisation balance 793.56Cr \n"
"Other details \n"
" \n"
" \n\n"
" \n"
" \n"
"Account balance PLM051 05May2016 10:54 \n\n"
" \n"
"Actions Submenu View authorisation balance details\n"
"View available balance detailsExit \n"
" \n"
" Product 40256731631234 BUSINESS A/C Zapp Innovat*BCA \n"
" \n"
"Balances as at 05May2016 10:54 except where indicated \n"
" Balance 907.50Cr \n"
" Statement balance 1,059.50Cr (04May2016) \n\n"
" Cleared balance 907.50Cr \n"
" Interest balance 1,059.50Cr (04May2016) \n"
" \n"
" Available balance 793.56Cr \n"
" Authorisation balance 793.56Cr \n"
"Other details \n"
" \n"
" \n\n"
" \n"
" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")