import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Product (\\d{6})(\\d{8}) (.{12}) (.+)\\s?\\*BCA)+";
final String string = "Account balance PLM051 05May2016 10:54 \n\n"
+ " \n"
+ "Actions Submenu View authorisation balance details\n"
+ "View available balance detailsExit \n"
+ " \n"
+ " Product 40256731631234 BUSINESS A/C Zapp Innovat*BCA \n"
+ " \n"
+ "Balances as at 05May2016 10:54 except where indicated \n"
+ " Balance 907.50Cr \n"
+ " Statement balance 1,059.50Cr (04May2016) \n\n"
+ " Cleared balance 907.50Cr \n"
+ " Interest balance 1,059.50Cr (04May2016) \n"
+ " \n"
+ " Available balance 793.56Cr \n"
+ " Authorisation balance 793.56Cr \n"
+ "Other details \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ "Account balance PLM051 05May2016 10:54 \n\n"
+ " \n"
+ "Actions Submenu View authorisation balance details\n"
+ "View available balance detailsExit \n"
+ " \n"
+ " Product 40256731631234 BUSINESS A/C Zapp Innovat*BCA \n"
+ " \n"
+ "Balances as at 05May2016 10:54 except where indicated \n"
+ " Balance 907.50Cr \n"
+ " Statement balance 1,059.50Cr (04May2016) \n\n"
+ " Cleared balance 907.50Cr \n"
+ " Interest balance 1,059.50Cr (04May2016) \n"
+ " \n"
+ " Available balance 793.56Cr \n"
+ " Authorisation balance 793.56Cr \n"
+ "Other details \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}