package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+\s+\S+\s+\S+\s+\S+\s+\S+\s+\S+\s+\S+\s+\S+\s+(.*)`)
var str = `drwxrwxr-x 2 bhannan bhannan 4096 Jun 2 11:27 HelloWorld.xml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}