package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w-]+(?:=>[\w-]+)?$`)
var str = `Field=>Value-True
=>False_name
Bad_name_2=>
foo
bar
foo=>=>bar
foo=>bar=>bam
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}