$re = '/^[\w-]+(?:=>[\w-]+)?$/m';
$str = 'Field=>Value-True
=>False_name
Bad_name_2=>
foo
bar
foo=>=>bar
foo=>bar=>bam
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);