re = /^[\w-]+(?:=>[\w-]+)?$/m
str = 'Field=>Value-True
=>False_name
Bad_name_2=>
foo
bar
foo=>=>bar
foo=>bar=>bam
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end