using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<error_count>[^,]*)";
string input = @"Error 1 , profileid = a, jsessionid=b
Error 1, profileid = c, jsessionid=d
Error 2 , profileid = e, jsessionid=f";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}