re = /^(?<error_count>[^,]*)/m
str = 'Error 1 , profileid = a, jsessionid=b
Error 1, profileid = c, jsessionid=d
Error 2 , profileid = e, jsessionid=f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end