$re = '/^(?<error_count>[^,]*)/m';
$str = 'Error 1 , profileid = a, jsessionid=b
Error 1, profileid = c, jsessionid=d
Error 2 , profileid = e, jsessionid=f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);