#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(M[1|2])?\s+(\D+)(\d{4})_(\d{4})"
Local $sString = "M1 hello world 1234_5678 ip som lorem 9321_1231 iste natus error sit voluptatem 4313_4351 ratione voluptatem sequi nesciunt 4312_1234" & @CRLF & _
"M2 magnam aliquam 4351_3143 sed quia non numquam 3123_1432"
Local $sSubst = "\1\t\2\t\3\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)