package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(M[1|2])?\s+(\D+)(\d{4})_(\d{4})`)
var str = `M1 hello world 1234_5678 ip som lorem 9321_1231 iste natus error sit voluptatem 4313_4351 ratione voluptatem sequi nesciunt 4312_1234
M2 magnam aliquam 4351_3143 sed quia non numquam 3123_1432`
var substitution = "\1\t\2\t\3\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}