import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(M[1|2])?\\s+(\\D+)(\\d{4})_(\\d{4})";
final String string = "M1 hello world 1234_5678 ip som lorem 9321_1231 iste natus error sit voluptatem 4313_4351 ratione voluptatem sequi nesciunt 4312_1234\n"
+ "M2 magnam aliquam 4351_3143 sed quia non numquam 3123_1432";
final String subst = "\\1\\t\\2\\t\\3\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}