package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https:\/\/www\.youtube\.com\/watch\?v=(\w+)`)
var str = `https://www.youtube.com/watch?v=jNQXAC9IVRw`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}