$re = '/https:\/\/www\.youtube\.com\/watch\?v=(\w+)/';
$str = 'https://www.youtube.com/watch?v=jNQXAC9IVRw';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);