re = /https:\/\/www\.youtube\.com\/watch\?v=(\w+)/
str = 'https://www.youtube.com/watch?v=jNQXAC9IVRw'
# Print the match result
str.match(re) do |match|
puts match.to_s
end