using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<p>|<div .*>)(\s*)(<a .*>)?(\s*)(<img .* \/>)(\s*)(<\/a>)?(\s*)(<p .*>.*<\/p>)?(\s*)(<\/p>|<\/div>)";
string substitution = @"$3$5$7$9";
string input = @"<div id=""attachment_3340"" style=""width: 865px"" class=""wp-caption alignnone"">
<img class=""size-full wp-image-3340"" alt=""Testbild"" src=""https://beispiel.de/images/Testbild.jpg"" width=""855"" height=""631"" />
<p class=""wp-caption-text"">© Copyright</p>
</div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}