$re = '/(<p>|<div .*>)(\s*)(<a .*>)?(\s*)(<img .* \/>)(\s*)(<\/a>)?(\s*)(<p .*>.*<\/p>)?(\s*)(<\/p>|<\/div>)/';
$str = '<div id="attachment_3340" style="width: 865px" class="wp-caption alignnone">
<img class="size-full wp-image-3340" alt="Testbild" src="https://beispiel.de/images/Testbild.jpg" width="855" height="631" />
<p class="wp-caption-text">© Copyright</p>
</div>';
$subst = "$3$5$7$9";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;