#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)\$" & @CRLF & _
"(?=[^$]{3,100}\$)" & @CRLF & _
"(?<PH>[A-Za-z0-9:_-]{1,20})" & @CRLF & _
"(?:" & @CRLF & _
" (?<C1>\/)" & @CRLF & _
" (?<RX>(?:[^\\\/\r\n]|\\\/?)*)" & @CRLF & _
" \/" & @CRLF & _
" (?:" & @CRLF & _
" (?<R>(?:[^\\\/\r\n$]|\\[\/$]?)*)" & @CRLF & _
" \/" & @CRLF & _
" |" & @CRLF & _
" (?<G>\d*)" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (?:" & @CRLF & _
" (?<C2>\()" & @CRLF & _
" (?<F>(?:[^\t\r\n\f()]|\\[()]?)*)" & @CRLF & _
" \)" & @CRLF & _
" )?" & @CRLF & _
")" & @CRLF & _
"\$"
Local $sString = " $EX1$ -> EX1" & @CRLF & _
" $EX2(a$b$c)$ -> EX2, (, a$b$c" & @CRLF & _
" $EX3(abc\x/)$ -> EX3, (, abc\x/" & @CRLF & _
" $EX4(\@\,/&/)$ -> EX4, (, \@\,/&/" & @CRLF & _
" $EX5/X(Z)Y/$ -> EX5, /, X(Z)Y" & @CRLF & _
" $EX6/X(ABC)/1$ -> EX6, /, X(ABC), 1" & @CRLF & _
" $EX7/X\\Z\/Y/$ -> EX7, /, X\\Z\/Y" & @CRLF & _
" $EX8/(A)/(B)/$ -> EX8, /, (A), (B)" & @CRLF & _
" $EX9/(\\$A$)\//(\\$B$\/)/$ -> EX9, /, (\\$A$)\/, (\\$B$\/)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Lorem Ip$um $EX1$i$ simply dummy $EX1$$EX2(abc)$ te$t of the printing and " & @CRLF & _
"type$EX2(abc)$etting indu$try. $EX3(abc\x/)$ Lorem $EX4(\@\,/&/)$Ipsum has been the " & @CRLF & _
"industry'$EX5/X(Z)Y/$ standard du$EX6/X(ABC)/1$mmy text $EX7/X\\Z\/Y/$ ever $$$ince the " & @CRLF & _
"1500$EX8/(A)/(B)/$, when an $ unknown $EX9/(\\$A$)\//(\\$B$\/)/$ printer took a galley of type "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")