import Foundation
let pattern = #"""
\$
(?=[^$]{3,100}\$)
(?<PH>[A-Za-z0-9:_-]{1,20})
(?:
(?<C1>\/)
(?<RX>(?:[^\\\/\r\n]|\\\/?)*)
\/
(?:
(?<R>(?:[^\\\/\r\n$]|\\[\/$]?)*)
\/
|
(?<G>\d*)
)
|
(?:
(?<C2>\()
(?<F>(?:[^\t\r\n\f()]|\\[()]?)*)
\)
)?
)
\$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
$EX1$ -> EX1
$EX2(a$b$c)$ -> EX2, (, a$b$c
$EX3(abc\x/)$ -> EX3, (, abc\x/
$EX4(\@\,/&/)$ -> EX4, (, \@\,/&/
$EX5/X(Z)Y/$ -> EX5, /, X(Z)Y
$EX6/X(ABC)/1$ -> EX6, /, X(ABC), 1
$EX7/X\\Z\/Y/$ -> EX7, /, X\\Z\/Y
$EX8/(A)/(B)/$ -> EX8, /, (A), (B)
$EX9/(\\$A$)\//(\\$B$\/)/$ -> EX9, /, (\\$A$)\/, (\\$B$\/)
Lorem Ip$um $EX1$i$ simply dummy $EX1$$EX2(abc)$ te$t of the printing and
type$EX2(abc)$etting indu$try. $EX3(abc\x/)$ Lorem $EX4(\@\,/&/)$Ipsum has been the
industry'$EX5/X(Z)Y/$ standard du$EX6/X(ABC)/1$mmy text $EX7/X\\Z\/Y/$ ever $$$ince the
1500$EX8/(A)/(B)/$, when an $ unknown $EX9/(\\$A$)\//(\\$B$\/)/$ printer took a galley of type
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)