import re
regex = re.compile(r"""
\$
(?=[^$]{3,100}\$)
(?<PH>[A-Za-z0-9:_-]{1,20})
(?:
(?<C1>\/)
(?<RX>(?:[^\\\/\r\n]|\\\/?)*)
\/
(?:
(?<R>(?:[^\\\/\r\n$]|\\[\/$]?)*)
\/
|
(?<G>\d*)
)
|
(?:
(?<C2>\()
(?<F>(?:[^\t\r\n\f()]|\\[()]?)*)
\)
)?
)
\$
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = (" $EX1$ -> EX1\n"
" $EX2(a$b$c)$ -> EX2, (, a$b$c\n"
" $EX3(abc\\x/)$ -> EX3, (, abc\\x/\n"
" $EX4(\\@\\,/&/)$ -> EX4, (, \\@\\,/&/\n"
" $EX5/X(Z)Y/$ -> EX5, /, X(Z)Y\n"
" $EX6/X(ABC)/1$ -> EX6, /, X(ABC), 1\n"
" $EX7/X\\\\Z\\/Y/$ -> EX7, /, X\\\\Z\\/Y\n"
" $EX8/(A)/(B)/$ -> EX8, /, (A), (B)\n"
" $EX9/(\\\\$A$)\\//(\\\\$B$\\/)/$ -> EX9, /, (\\\\$A$)\\/, (\\\\$B$\\/)\n\n\n"
"Lorem Ip$um $EX1$i$ simply dummy $EX1$$EX2(abc)$ te$t of the printing and \n"
"type$EX2(abc)$etting indu$try. $EX3(abc\\x/)$ Lorem $EX4(\\@\\,/&/)$Ipsum has been the \n"
"industry'$EX5/X(Z)Y/$ standard du$EX6/X(ABC)/1$mmy text $EX7/X\\\\Z\\/Y/$ ever $$$ince the \n"
"1500$EX8/(A)/(B)/$, when an $ unknown $EX9/(\\\\$A$)\\//(\\\\$B$\\/)/$ printer took a galley of type ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")