#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((ftp|http):\/\/)?(w{3})?\.([a-zA-Z0-9.-]+)\.([a-z]{2}|([a-z]{2,3}\.[a-z]{2}))"
Local $sString = "ftp://www.sass32.cosssssss.msdd" & @CRLF & _
"" & @CRLF & _
"http://"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")