using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((ftp|http):\/\/)?(w{3})?\.([a-zA-Z0-9.-]+)\.([a-z]{2}|([a-z]{2,3}\.[a-z]{2}))";
string input = @"ftp://www.sass32.cosssssss.msdd
http://";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}