const regex = /((ftp|http):\/\/)?(w{3})?\.([a-zA-Z0-9.-]+)\.([a-z]{2}|([a-z]{2,3}\.[a-z]{2}))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((ftp|http):\\\/\\\/)?(w{3})?\\.([a-zA-Z0-9.-]+)\\.([a-z]{2}|([a-z]{2,3}\\.[a-z]{2}))', 'g')
const str = `ftp://www.sass32.cosssssss.msdd
http://`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}