#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(http:|https:|)\/\/(player.|www.)?(vimeo\.com|youtu(be\.com|\.be|be\.googleapis\.com|be\-nocookie\.com))\/(video\/|embed\/|watch\?\S*v=|v\/)?([A-Za-z0-9._%-]*)(\&\S+)?"
Local $sString = "http://www.youtube.com/watch?v=My2FRPA3Gf8" & @CRLF & _
"http://youtu.be/My2FRPA3Gf8" & @CRLF & _
"https://youtube.googleapis.com/v/My2FRPA3Gf8" & @CRLF & _
"http://www.youtube.com/embed/Ab25nviakcw" & @CRLF & _
"http://www.youtube-nocookie.com/v/Ab25nviakcw?version=3&hl=en_US" & @CRLF & _
"http://www.youtube.com/watch?feature=player_embedded&v=Ab25nviakcw#" & @CRLF & _
"" & @CRLF & _
"http://vimeo.com/25451551" & @CRLF & _
"http://player.vimeo.com/video/25451551" & @CRLF & _
"//player.vimeo.com/video/25451551" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)