import re
regex = re.compile(r"(http:|https:|)\/\/(player.|www.)?(vimeo\.com|youtu(be\.com|\.be|be\.googleapis\.com|be\-nocookie\.com))\/(video\/|embed\/|watch\?\S*v=|v\/)?([A-Za-z0-9._%-]*)(\&\S+)?")
test_str = ("http://www.youtube.com/watch?v=My2FRPA3Gf8\n"
"http://youtu.be/My2FRPA3Gf8\n"
"https://youtube.googleapis.com/v/My2FRPA3Gf8\n"
"http://www.youtube.com/embed/Ab25nviakcw\n"
"http://www.youtube-nocookie.com/v/Ab25nviakcw?version=3&hl=en_US\n"
"http://www.youtube.com/watch?feature=player_embedded&v=Ab25nviakcw#\n\n"
"http://vimeo.com/25451551\n"
"http://player.vimeo.com/video/25451551\n"
"//player.vimeo.com/video/25451551\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)