import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:|https:|)\\/\\/(player.|www.)?(vimeo\\.com|youtu(be\\.com|\\.be|be\\.googleapis\\.com|be\\-nocookie\\.com))\\/(video\\/|embed\\/|watch\\?\\S*v=|v\\/)?([A-Za-z0-9._%-]*)(\\&\\S+)?";
final String string = "http://www.youtube.com/watch?v=My2FRPA3Gf8\n"
+ "http://youtu.be/My2FRPA3Gf8\n"
+ "https://youtube.googleapis.com/v/My2FRPA3Gf8\n"
+ "http://www.youtube.com/embed/Ab25nviakcw\n"
+ "http://www.youtube-nocookie.com/v/Ab25nviakcw?version=3&hl=en_US\n"
+ "http://www.youtube.com/watch?feature=player_embedded&v=Ab25nviakcw#\n\n"
+ "http://vimeo.com/25451551\n"
+ "http://player.vimeo.com/video/25451551\n"
+ "//player.vimeo.com/video/25451551\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}