import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "key: \\'(.*?)\\',\\s*$";
final String string = " var newEncryptMode = ''\n"
+ " var Encrypt = {\n"
+ " key: 'a2ffa5c9be07488bbb04a3a47d3c5f6a',\n"
+ " iv: '64175472480004614961023454661220',\n"
+ " nonce: null,\n"
+ " init: function () {\n"
+ " var nonce = this.nonceCreat();\n"
+ " this.nonce = nonce;\n"
+ " return this.nonce;\n"
+ " },\n"
+ " nonceCreat: function () {\n"
+ " var type = 0;\n"
+ " var deviceId = 'f8:b4:6a:aa:5d:96';\n"
+ " var time = Math.floor(new Date().getTime() / 1000);\n"
+ " var random = Math.floor(Math.random() * 10000);\n"
+ " return [type, deviceId, time, random].join('_');\n"
+ " },\n"
+ " oldPwd: function (pwd) {\n"
+ " if(newEncryptMode == 1){\n"
+ " return CryptoJS.SHA256(this.nonce + CryptoJS.SHA256(pwd + this.key).toString()).toString();\n"
+ " }else{\n"
+ " return CryptoJS.SHA1(this.nonce + CryptoJS.SHA1(pwd + this.key).toString()).toString();\n"
+ " }\n\n"
+ " },";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}