import re
regex = re.compile(r"key: \'(.*?)\',\s*$", flags=re.MULTILINE)
test_str = (" var newEncryptMode = ''\n"
" var Encrypt = {\n"
" key: 'a2ffa5c9be07488bbb04a3a47d3c5f6a',\n"
" iv: '64175472480004614961023454661220',\n"
" nonce: null,\n"
" init: function () {\n"
" var nonce = this.nonceCreat();\n"
" this.nonce = nonce;\n"
" return this.nonce;\n"
" },\n"
" nonceCreat: function () {\n"
" var type = 0;\n"
" var deviceId = 'f8:b4:6a:aa:5d:96';\n"
" var time = Math.floor(new Date().getTime() / 1000);\n"
" var random = Math.floor(Math.random() * 10000);\n"
" return [type, deviceId, time, random].join('_');\n"
" },\n"
" oldPwd: function (pwd) {\n"
" if(newEncryptMode == 1){\n"
" return CryptoJS.SHA256(this.nonce + CryptoJS.SHA256(pwd + this.key).toString()).toString();\n"
" }else{\n"
" return CryptoJS.SHA1(this.nonce + CryptoJS.SHA1(pwd + this.key).toString()).toString();\n"
" }\n\n"
" },")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")