using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\s)@([^@\s]+)(?<!rb)\b";
string input = @"@ajksdh
@kajshd123
@12398asdd
@72rb
@80rb";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}