$re = '/(?<=^|\s)@([^@\s]+)(?<!rb)\b/';
$str = '@ajksdh
@kajshd123
@12398asdd
@72rb
@80rb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);