re = /(?<=^|\s)@([^@\s]+)(?<!rb)\b/
str = '@ajksdh
@kajshd123
@12398asdd
@72rb
@80rb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end