package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http:\/\/(.*?).flv`)
var str = `http://www.somesite.com/ac.flv`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}