const regex = /http:\/\/(.*?).flv/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/(.*?).flv', '')
const str = `http://www.somesite.com/ac.flv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}