#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)/(?:/.*?$|\*.*?\*/)"
Local $sString = "// Systme.out.println (obj1.getMessage()); //line1" & @CRLF & _
"/* Systme.out.println (obj.getMessage());*/ //line2 " & @CRLF & _
"/* public void test() { //line3 " & @CRLF & _
" Systme.out.println (obj2.getMessage()); //line4" & @CRLF & _
" } //line5" & @CRLF & _
"*/ " & @CRLF & _
"public void test() { " & @CRLF & _
" Systme.out.println (obj5.getMessage()); //line 6" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")