using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)/(?:/.*?$|\*.*?\*/)";
string input = @"// Systme.out.println (obj1.getMessage()); //line1
/* Systme.out.println (obj.getMessage());*/ //line2
/* public void test() { //line3
Systme.out.println (obj2.getMessage()); //line4
} //line5
*/
public void test() {
Systme.out.println (obj5.getMessage()); //line 6
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}