import Foundation
let pattern = #"(?ms)/(?:/.*?$|\*.*?\*/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
// Systme.out.println (obj1.getMessage()); //line1
/* Systme.out.println (obj.getMessage());*/ //line2
/* public void test() { //line3
Systme.out.println (obj2.getMessage()); //line4
} //line5
*/
public void test() {
Systme.out.println (obj5.getMessage()); //line 6
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)