using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!`)big(?!.*`)";
string input = @"Should Match: I like big cakes
Should Match: I like `big cakes
Should Match: I like big` cakes
Should Match: I like xx big xx cakes
Should Match: I like ` xx big xx cakes
Should Match: I like xx big xx` cakes
Should not Match: I like `big` cakes
Should not Match: I like `xx big xx` cakes";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}