re = /(?<!`)big(?!.*`)/
str = 'Should Match: I like big cakes
Should Match: I like `big cakes
Should Match: I like big` cakes
Should Match: I like xx big xx cakes
Should Match: I like ` xx big xx cakes
Should Match: I like xx big xx` cakes
Should not Match: I like `big` cakes
Should not Match: I like `xx big xx` cakes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end