$re = '/(?<!`)big(?!.*`)/';
$str = 'Should Match: I like big cakes
Should Match: I like `big cakes
Should Match: I like big` cakes
Should Match: I like xx big xx cakes
Should Match: I like ` xx big xx cakes
Should Match: I like xx big xx` cakes
Should not Match: I like `big` cakes
Should not Match: I like `xx big xx` cakes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);