const regex = new RegExp('[_+!@#$?^]+$', 'gm')
const str = `string01_
str_ing02_^
string03_@_
string04_1
string05_a_
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);