import re
regex = re.compile(r"[_+!@#$?^]+$", flags=re.MULTILINE)
test_str = ("string01_\n"
"str_ing02_^\n"
"string03_@_\n"
"string04_1\n"
"string05_a_\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)