re = /[_+!@#$?^]+$/m
str = 'string01_
str_ing02_^
string03_@_
string04_1
string05_a_
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result